spaghetti supports python 3.5 and 3.6 only. Please make sure that you are operating in a python 3 environment.

Installation

Development Version

Install the most current development version of spaghetti by running:

$ pip install git+https://github.com/pysal/spaghetti

You can also fork the pysal/spaghetti repo and create a local clone of your fork. By making changes to your local clone and submitting a pull request to pysal/spaghetti, you can contribute to the giddy development.